Keystone RV Forums
 

Go Back   Keystone RV Forums > General Forums > Repairs & Maintenance

Reply
 
Thread Tools Display Modes
  #1  
Old 09-05-2011, 04:14 PM
Bill Ruddell Bill Ruddell is offline
Junior Member
 
Join Date: Dec 2010
Posts: 9
Default Landing gear problem

My unit is a 2008 Laredo 315RL

Last time out, without warning, the landing gear would retract but NOT extend. I did NOT switch the leads at the motor to see if I could "reverse" the situation - so hopefully it is the switch itself.

The replacement switch (from Keystone) has the correct number of leads (4) in the harness, but the colors are slightly different from the original.

What is the proper procedure: disconnect battery / remove battery - don't want to blow up anything or shock myself.

Thank you for your help, tips, suggestions,
Bill Ruddell
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 09:05 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
This forum is owned and operated by Superior Network Solutions, Inc., a California corporation. It is not authorized or endorsed by the Keystone RV Company and is not affiliated with the Keystone RV Company or its related companies in any way. Keystone RV® is a registered trademark of the Keystone RV Company.